Home > BGP Questions

BGP Questions

May 7th, 2017 Go to comments

Note: If you are not sure about BGP, please read our BGP Tutorial.

Question 1

Explanation

This command can be used to verify if a BGP connection to a BGP neighbor is good or not. Let’s see an example:

BGP_States.jpg

Please pay attention to the “State/PfxRcd” column of the output. It indicates the number of prefixes that have been received from a neighbor. If this value is a number (including “0”, which means BGP neighbor does not advertise any route) then the BGP neighbor relationship is good. If this value is a word (including “Idle”, “Connect”, “Active”, “OpenSent”, “OpenConfirm”) then the BGP neighbor relationship is not good.

In the outputs above we see the BGP neighbor relationship between R1 & 10.1.1.1 is good with 2 Prefix Received (PfxRcd) while the BGP neighbor relationships between R1 & 10.2.2.2; R1 & 10.3.3.3 are not good (they are in “Active” and “Idle” state).

Question 2

Explanation

This is an example of how to configure BGP neighbor between two routers (suppose all interfaces are configured correctly)

BGP_Config.jpg

R1(config)#router bgp 1
R1(config-router)#neighbor 11.0.0.2 remote-as 2
R2(config)#router bgp 2
R2(config-router)#neighbor 11.0.0.1 remote-as 1

So as you see, we need the neighbor’s IP address and neighbor’s AS number for the BGP neighbor relationship.

Question 3

Explanation

First please notice that unlike other routing protocols like OSPF or EIGRP, we have to use subnet mask, not wildcard mask, to advertise the routes in the “network” command -> C is not correct.

Secondly, with BGP, you must advertise the correct network and subnet mask in the “network” command ( in this case network 172.16.1.32/27). BGP is very strict in the routing advertisements. In other words, BGP only advertises the network which exists exactly in the routing table (in this case network x.x.x.32/27 exists in the routing table as the Fa0/0 interface). If you put the command “network x.x.0.0 mask 255.255.0.0” or “network x.0.0.0 mask 255.0.0.0” or “network x.x.x.33 mask 255.255.255.255” then BGP will not advertise anything.

Therefore the full command in this question is “network 172.16.1.32 mask 255.255.255.224”.

For more information about BGP configuration, please read our Basic BGP Configuration tutorial.

Comments (18) Comments
  1. question 3
    March 3rd, 2017

    Why is . x.x.x.33 mask 255.255.255.224 not correct

  2. NN
    March 5th, 2017

    Why is . x.x.x.33 mask 255.255.255.224 not correct [2]

  3. dimemolight
    March 8th, 2017

    because network address is x.x.x.32

  4. deadcell
    March 29th, 2017

    it is correct only…

  5. Anonymous
    May 2nd, 2017

    b/c the network address is x.x.x.32

  6. Merlin
    June 13th, 2017

    Passed today, used the 747q dumps.

  7. Parthi
    June 17th, 2017

    @Merlin

    I planned to write the exam in next week
    Pls share the dumbs aktparthiban @ gmail . com

  8. @Bcc
    June 23rd, 2017

    Please provide the link to 747q

  9. BPM
    July 8th, 2017

    necesitas anunciar el ID de red, no la ip de la interface. ;D

  10. Mik
    July 14th, 2017

    Please share the dumps {email not allowed}

  11. Mik
    July 14th, 2017

    July 14th, 2017
    Please share the dumps to Michael Andrew Snee @ gmail . com

  12. Anonymous
    July 24th, 2017

    Why answer x.x.x.32 is correct rather x.x.x.33

    ip address 172.16.1.32 need to advertise on BGP
    WHy
    172.16.1.32 mask 255.255.255.224 is correct

  13. Syed S Rahmani
    July 24th, 2017

    Why answer x.x.x.32 is correct rather x.x.x.33

    ip address 172.16.1.32 need to advertise on BGP
    WHy
    172.16.1.32 mask 255.255.255.224 is correct

  14. louys
    August 8th, 2017

    Could someone send me a least dump?
    lajos . berczi @ gmail . com

    Thank you!

  15. Mo
    August 16th, 2017

    Pls share the lastest dump
    {email not allowed}

  16. rolllaverge
    August 17th, 2017

    There’s a mistake in Q3 because in BGP you have to advertise the exact route known in the routing table, in this case it is 172.16.1.33 (directly connected)

    the given information is:
    interface fa0/0
    ip address 172.16.1.33 255.255.255.224

  17. walker
    August 31st, 2017

    How to configure BGP over PPPoE?
    {email not allowed}

  18. Bhagya
    October 24th, 2017

    Merlin, can you send me too 747q dumps, bhagyaf@gmail . com. ??

Add a Comment